PDA

View Full Version : Guess what guys!!:)


danieljay
07-31-2009, 07:33 AM
Some good news from me for a change.I'd like you all,and to all the helpers with my computer/FL Studio playback problem is fixed!!

There's a switch in FL called "Multithreaded processing"once a switched this off,it worked like a charm.It has such smooth playback.No clicks,pops or anything,i can even skip thorugh the song with no troubles,even the rendering is better.I thought i'd also inform you all incase you're ever going to encounter the same problem as i had.Just turn the multithreaded switch off,this is for 64bit users most likely running something like an up to date i7 like me,or anything else in this era of computer technology.Thanks.

persentio
07-31-2009, 07:37 AM
Wow great!! FINALLY you can get back to a fuss-free environment eh?

Qutie a pity though since the i7s are SUPPOSED to be used with multi threaded applications.. But I guess FL Studio really needs to work on that.

halftone
07-31-2009, 07:43 AM
Hi Dan,

I am glad to hear you have cleared that up. Software problems are so frustrating!!

Regards John

LEX
07-31-2009, 11:24 AM
Well, it may work but from what it looks like, you are turning of multi core processing as well.

So having a quad core, dual quad means nothing then.

With it off, you should check your task manager to see how the CPU processes are distributed across all the cores.

Another thing you could try with MP on, if change the affinity of the FL. 0 to 1 or 1 to 0.

LEX

GtrJazz
07-31-2009, 11:50 AM
Why not just switch to sonar. It should be able to use hyper threading in 64 bit.

interpolate
07-31-2009, 12:05 PM
Also consider Cubase 5. But in reality, it's up to you what you use.

danieljay
07-31-2009, 04:49 PM
Yeah,it does seem strange that MP would make things dodgy.Yes, i think FL should fix this.

adic27
07-31-2009, 05:52 PM
Yeah this is suggested by the guys over at Image Line. You should post on the IL forms and maybe by FL 9 it will be resolved.

I to use FL so congrats! :)

danieljay
07-31-2009, 08:32 PM
Hi,yeah i am over at IL-i have the same name.You'll see in tech support that i've posted about this.

danieljay
08-01-2009, 01:16 AM
.............I just had a jinx.It's doing it again,regardless of MP turned off.:(

interpolate
08-01-2009, 01:48 PM
If you go into the task manager of Windows, you can change the processor affinity settings which in layperson terms means it tells Windows not to use all the cores on the FLStudio process.

interpolate
08-01-2009, 01:53 PM
This will of course Windows will only run that process on that one core though which means a reduction in the Core i7's performance. Nothing personal, however I think you are making life harder for yourself by knowingly using software which isn't doing what you need it too.

http://www.windowsnetworking.com/articles_tutorials/Processor-Affinity.html

danieljay
08-06-2009, 06:33 AM
Ok so i was fiddling around with FL Studio tonight. I came across a problem, every time i turn my midi controller on it makes it run buggy, so what i did was, i went into the midi directory, where the port numbers are. I set the port number so that it had no port number at all, i did this with every midi controller i have. This seemed to fix the problem. Haha, for real though, i'm not getting my hopes up, i mean how many times have a thought i found a solution.

For now it's working fine, maybe some port numbers i set the controllers at were making it buggy some how. Lol, as if that would be it.

Couple of words for everyone here, computers...... are....... stupid.