PDA

View Full Version : Sherlock holmes with clicks


RobertPeeters
03-29-2012, 02:25 PM
Hey

Here's my latest upload, an arrangement of the main theme of Sherlock Holmes by Hans Zimmer.
It is with clicks in it, thanks to the buggy Play...

http://www.youtube.com/watch?v=3G_zpqn6k6s

aptmusic9
03-29-2012, 03:44 PM
changing buffer sizes helped me solve clicks....even though 128 isnt reasonable buffer to run at, if you change it to 128 before exporting it might help theclicks

RobertPeeters
03-29-2012, 05:07 PM
Thanx for your advice, but I already tried that, didn't work..

lejmer
03-29-2012, 05:26 PM
Streaming too many samples for your harddrive to handle? Don't blame everything on the software!

aptmusic9
03-29-2012, 11:36 PM
Streaming too many samples for your harddrive to handle? Don't blame everything on the software!

Yea but the problem he's describing is the kind that comes out in the audio exports. Ideally there shouldn't be any pops in the export, even if one's computer is overloading and having pops during live playback in the DAW.

lejmer
03-30-2012, 02:58 AM
Yea but the problem he's describing is the kind that comes out in the audio exports. Ideally there shouldn't be any pops in the export, even if one's computer is overloading and having pops during live playback in the DAW.

True, but as there are hardware problems involved, it is hard to stop. From a programming point of view, how are the program going to know when a harddrive is not fast enough to stream more samples? The only solution I can think of is a multipass rendering process, that renders the song one time, then analyses it for typical clicks or white noises that can sometimes happen, and then on the second pass only renders those parts that had noises, with a second or two headstart. That's the only way I can think of that would make clicks less probable in an audio export. However, this would not be a Play feature, but rather a feature of the host itself, and thusly we cannot blame Play for it.

lejmer
03-30-2012, 03:03 AM
The arrangement was nice! I don't usually like this theme, but you made it interesting! :) Great job! And great playing!

RobertPeeters
03-30-2012, 04:19 AM
Thanx for your replies!
It is definitely a bug, since I didn't have the problem with Play 2, but that came with the sustain problem, that's why I updated :)

Dean
03-30-2012, 11:44 AM
When bouncing/exporting audio you could set your DAWs buffer to max 1024 should eliminate any clicks and pops even with H .Strings.

Latency is not an issue,..only when you're performing/composing. D